use strict;
my $str = 'focus;focus#focus#focus focus';
my $regex = qr/(?<!#)(focus)(?!#)/mp;
my $subst = 'ale';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";