# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*'\B|\B'\s*//g;t' <<< "I don't know 'how' to remove these ' things"