$re = '/\s*\'\B|\B\'\s*/';
$str = 'I don\'t know \'how\' to remove these \' things';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;