re = /\s*'\B|\B'\s*/
str = 'I don\'t know \'how\' to remove these \' things'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result