const regex = /\<(\w+)\>([^<>]*)\<\/\1\>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\<(\\w+)\\>([^<>]*)\\<\\\/\\1\\>', 'gm')
const str = `<tag> <Arial>This is a text</Arial></tag>`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);