re = /\<(\w+)\>([^<>]*)\<\/\1\>/m
str = '<tag> <Arial>This is a text</Arial></tag>'
subst = '$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result