using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^apple\R(?>(?(?=(?R))(*SKIP)(*F)).*\R)*?banana\R(?>(?(?=(?R))(*SKIP)(*F)).*\R)*?orange$";
string input = @"apple
orange
apple
banana
apple
test
banana
apple
orange
hmm
orange
apple
orange
orange
lemon
apple
banana
apple
bananabad
orange
goood
banana
apple
fun
banana
stuff
more stuff
orange
avocado";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}