const regex = /^apple\R(?>(?(?=(?R))(*SKIP)(*F)).*\R)*?banana\R(?>(?(?=(?R))(*SKIP)(*F)).*\R)*?orange$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^apple\\R(?>(?(?=(?R))(*SKIP)(*F)).*\\R)*?banana\\R(?>(?(?=(?R))(*SKIP)(*F)).*\\R)*?orange$', 'gm')
const str = `apple
orange
apple
banana
apple
test
banana
apple
orange
hmm
orange
apple
orange
orange
lemon
apple
banana
apple
bananabad
orange
goood
banana
apple
fun
banana
stuff
more stuff
orange
avocado`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}