$re = '/^apple\R(?>(?(?=(?R))(*SKIP)(*F)).*\R)*?banana\R(?>(?(?=(?R))(*SKIP)(*F)).*\R)*?orange$/m';
$str = 'apple
orange
apple
banana
apple
test
banana
apple
orange
hmm
orange
apple
orange
orange
lemon
apple
banana
apple
bananabad
orange
goood
banana
apple
fun
banana
stuff
more stuff
orange
avocado';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);