#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.{201})(?=(.{0,63}[^\.]@.{1,255}))(?!.*[.?]{2})([!#$%&'*+\-\/=?\^_`{|}~a-zA-Z0-9}]{1,64}(\.[!#$%&'*+\-\/=?\^_`{|}~a-zA-Z0-9]{0,}){0,})@((\[(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)){3}\])|([a-zA-Z0-9-]{1,63}(\.[a-zA-Z0-9-]{2,63}){1,}))$"
Local $sString = "foo@bar.baz" & @CRLF & _
"" & @CRLF & _
"1000110001100011000110001100011000110001100011000110001100111111@1000110001100011000110001100011000110001100011000110001100.1231231323123123123123123123123123123123123123ss.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.adsadasdadsadsadasdasdadsas.asdasdasdasdasdasdasdasd.asdasdasdasdasd.1231231231sadsa.comsss"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")