import re
regex = re.compile(r"^(?!.{201})(?=(.{0,63}[^\.]@.{1,255}))(?!.*[.?]{2})([!#$%&'*+\-\/=?\^_`{|}~a-zA-Z0-9}]{1,64}(\.[!#$%&'*+\-\/=?\^_`{|}~a-zA-Z0-9]{0,}){0,})@((\[(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)){3}\])|([a-zA-Z0-9-]{1,63}(\.[a-zA-Z0-9-]{2,63}){1,}))$", flags=re.MULTILINE)
test_str = ("foo@bar.baz\n\n"
"1000110001100011000110001100011000110001100011000110001100111111@1000110001100011000110001100011000110001100011000110001100.1231231323123123123123123123123123123123123123ss.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.adsadasdadsadsadasdasdadsas.asdasdasdasdasdasdasdasd.asdasdasdasdasd.1231231231sadsa.comsss")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")