$re = '/^(?!.{201})(?=(.{0,63}[^\.]@.{1,255}))(?!.*[.?]{2})([!#$%&\'*+\-\/=?\^_`{|}~a-zA-Z0-9}]{1,64}(\.[!#$%&\'*+\-\/=?\^_`{|}~a-zA-Z0-9]{0,}){0,})@((\[(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)){3}\])|([a-zA-Z0-9-]{1,63}(\.[a-zA-Z0-9-]{2,63}){1,}))$/m';
$str = 'foo@bar.baz
1000110001100011000110001100011000110001100011000110001100111111@1000110001100011000110001100011000110001100011000110001100.1231231323123123123123123123123123123123123123ss.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.asdasdasdasdasdadsadsadadsadas.adsadasdadsadsadasdasdadsas.asdasdasdasdasdasdasdasd.asdasdasdasdasd.1231231231sadsa.comsss';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);