const regex = /.*3.([A-Za-z]*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*3.([A-Za-z]*)', '')
const str = `1.Apple 2.Orange 3.Grape`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}