$re = '/.*(Str\d+)(?=[^\[\]]*\])/U';
$str = 'a b c d [a b c Str1 d e f Str2 g h i Str3 ] e f g Str4 [Str5 a b c Str6 d] h i [ h i ]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);