import re
regex = re.compile(r".*(Str\d+)(?=[^\[\]]*\])")
test_str = ("a b c d [a b c Str1 d e f Str2 g h i Str3 ] e f g Str4 [Str5 a b c Str6 d] h i [ h i ]\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")