re = /.*(Str\d+)(?=[^\[\]]*\])/
str = 'a b c d [a b c Str1 d e f Str2 g h i Str3 ] e f g Str4 [Str5 a b c Str6 d] h i [ h i ]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end