package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:(?:\\+|0{0,2})91(\\s*[\\- ]\\s*)?|[0 ]?)?[789]\\d{9}|(\\d[ -]?){10}\\d`)
var str = `555-555-5555
(555)555-5555
(555) 555-5555
555 555 5555
5555555555
1 555 555 5555
1-555-555-5555
1.555.555.5555`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}