$re = '/(?:(?:\\\\+|0{0,2})91(\\\\s*[\\\\- ]\\\\s*)?|[0 ]?)?[789]\\\\d{9}|(\\\\d[ -]?){10}\\\\d/';
$str = '555-555-5555
(555)555-5555
(555) 555-5555
555 555 5555
5555555555
1 555 555 5555
1-555-555-5555
1.555.555.5555';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);