#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?:#IF\s(?:false)\n).*)|(?:#IF true\n)(?<=#IF true\n)|(?:#ENDIF)\n?"
Local $sString = "#IF false" & @CRLF & _
"If true the text should remain, else it should be deleted" & @CRLF & _
"#ENDIF" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"#IF true" & @CRLF & _
"If true the text should remain, else it should be deleted" & @CRLF & _
"#ENDIF" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")