$re = '/(?:(?:#IF\s(?:false)\n).*)|(?:#IF true\n)(?<=#IF true\n)|(?:#ENDIF)\n?/m';
$str = '#IF false
If true the text should remain, else it should be deleted
#ENDIF
#IF true
If true the text should remain, else it should be deleted
#ENDIF
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);