import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:#IF\\s(?:false)\\n).*)|(?:#IF true\\n)(?<=#IF true\\n)|(?:#ENDIF)\\n?";
final String string = "#IF false\n"
+ "If true the text should remain, else it should be deleted\n"
+ "#ENDIF\n\n\n\n"
+ "#IF true\n"
+ "If true the text should remain, else it should be deleted\n"
+ "#ENDIF\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}