#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?:(?:\^M)|[\n\r])+(id=.*)(?=(?:\^M)|[\n\r])"
Local $sString = "POST / HTTP/1.1^M" & @CRLF & _
"User-Agent: curl/7.27.0^M" & @CRLF & _
"Host: 127.0.0.1^M" & @CRLF & _
"Accept: */*^M" & @CRLF & _
"Content-Length: 55^M" & @CRLF & _
"Content-Type: application/x-www-form-urlencoded^M" & @CRLF & _
"^M" & @CRLF & _
"id=1234&var=test&nextvar=hh%20hg&anothervar=BB55SSKKKkk^M"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")