import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:\\^M)|[\\n\\r])+(id=.*)(?=(?:\\^M)|[\\n\\r])";
final String string = "POST / HTTP/1.1^M\n"
+ "User-Agent: curl/7.27.0^M\n"
+ "Host: 127.0.0.1^M\n"
+ "Accept: */*^M\n"
+ "Content-Length: 55^M\n"
+ "Content-Type: application/x-www-form-urlencoded^M\n"
+ "^M\n"
+ "id=1234&var=test&nextvar=hh%20hg&anothervar=BB55SSKKKkk^M";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}