import re
regex = re.compile(r"(?:(?:\^M)|[\n\r])+(id=.*)(?=(?:\^M)|[\n\r])", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("POST / HTTP/1.1^M\n"
"User-Agent: curl/7.27.0^M\n"
"Host: 127.0.0.1^M\n"
"Accept: */*^M\n"
"Content-Length: 55^M\n"
"Content-Type: application/x-www-form-urlencoded^M\n"
"^M\n"
"id=1234&var=test&nextvar=hh%20hg&anothervar=BB55SSKKKkk^M")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")