re = /(?<=moving towards )[^-.]*/
str = 'World is moving towards a particular point'
# Print the match result
str.match(re) do |match|
puts match.to_s
end