package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`:(.*?):`)
var str = `--:text in here:--:another one:-:third one:---!123:fourth:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}