$re = '/:(.*?):/';
$str = '--:text in here:--:another one:-:third one:---!123:fourth:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);