re = /:(.*?):/
str = '--:text in here:--:another one:-:third one:---!123:fourth:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end