# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:[^\r\n]+\R){2}\K[^\r\n]+(?:\R|$)//gm;t' <<< "tom
tim
john
will
tod
hello
test
ttt
three"