use strict;
my $str = 'tom
tim
john
will
tod
hello
test
ttt
three';
my $regex = qr/(?:[^\r\n]+\R){2}\K[^\r\n]+(?:\R|$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";