$re = '/(?:[^\r\n]+\R){2}\K[^\r\n]+(?:\R|$)/m';
$str = 'tom
tim
john
will
tod
hello
test
ttt
three';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;