package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:USD|usd)\s+.*?(\d+(?:\.\d{1,2})?)`)
var str = `I have usd **12** only.
I have usd 12.00 only.
I have usd **** 12.0 **** only.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}