$re = '/(?:USD|usd)\s+.*?(\d+(?:\.\d{1,2})?)/m';
$str = 'I have usd **12** only.
I have usd 12.00 only.
I have usd **** 12.0 **** only.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);