const regex = /(?:USD|usd)\s+.*?(\d+(?:\.\d{1,2})?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:USD|usd)\\s+.*?(\\d+(?:\\.\\d{1,2})?)', 'gm')
const str = `I have usd **12** only.
I have usd 12.00 only.
I have usd **** 12.0 **** only.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}