const regex = /.*setTwid\("([^"]+)", "([^"]+)", "([^"]+)"\).*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*setTwid\\("([^"]+)", "([^"]+)", "([^"]+)"\\).*', '')
const str = `try {
setTwid("http://arsdnet.net/this-week-in-d/2017-may-28.html", "May 28", "\`!@#\$%%^&((*(*()_€€");
} catch(e) {}`;
const subst = `TWID_LATEST_LINK=\1|TWID_LATEST_DATE=\2|TWID_LATEST_TITLE=\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);