re = /.*setTwid\("([^"]+)", "([^"]+)", "([^"]+)"\).*/
str = 'try {
setTwid("http://arsdnet.net/this-week-in-d/2017-may-28.html", "May 28", "`!@#$%%^&((*(*()_€€");
} catch(e) {}'
subst = 'TWID_LATEST_LINK=\\1|TWID_LATEST_DATE=\\2|TWID_LATEST_TITLE=\\3'
result = str.sub(re, subst)
# Print the result of the substitution
puts result