// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#".*setTwid\("([^"]+)", "([^"]+)", "([^"]+)"\).*"#).unwrap();
let string = "try {
setTwid(\"http://arsdnet.net/this-week-in-d/2017-may-28.html\", \"May 28\", \"`!@#$%%^&((*(*()_€€\");
} catch(e) {}";
let substitution = "TWID_LATEST_LINK=\\1|TWID_LATEST_DATE=\\2|TWID_LATEST_TITLE=\\3";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}