package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\$\d{1,3}(?:,\d{3})*`)
var str = `$65,000 /year for 2 years
Total of $120,000 ($60,000 per annum)
$40,000.0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}