$re = '/\$\d{1,3}(?:,\d{3})*/';
$str = '$65,000 /year for 2 years
Total of $120,000 ($60,000 per annum)
$40,000.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);