re = /\$\d{1,3}(?:,\d{3})*/
str = '$65,000 /year for 2 years
Total of $120,000 ($60,000 per annum)
$40,000.0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end