using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<count>\d+?)(?:d|D)(?P<dice>\d+)(?P<modifer_sign>\+|\-)(?P<modifier>\d+)$";
string input = @"4d100+47";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}