const regex = new RegExp('^(?P<count>\\d+?)(?:d|D)(?P<dice>\\d+)(?P<modifer_sign>\\+|\\-)(?P<modifier>\\d+)$', 'g')
const str = `4d100+47`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}