re = /^(?P<count>\d+?)(?:d|D)(?P<dice>\d+)(?P<modifer_sign>\+|\-)(?P<modifier>\d+)$/
str = '4d100+47'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end