#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?<=^|\s)(@[\w.]+)(?<!\.)"
Local $sString = "Hello, @username" & @CRLF & _
"Hello, @username." & @CRLF & _
"Hello, @user.name." & @CRLF & _
"Go to https://google.com/@username" & @CRLF & _
"@username says hello." & @CRLF & _
"@user.name says hello." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")