re = /(?<=^|\s)(@[\w.]+)(?<!\.)/i
str = 'Hello, @username
Hello, @username.
Hello, @user.name.
Go to https://google.com/@username
@username says hello.
@user.name says hello.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end