using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^|\s)(@[\w.]+)(?<!\.)";
string input = @"Hello, @username
Hello, @username.
Hello, @user.name.
Go to https://google.com/@username
@username says hello.
@user.name says hello.
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}