package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9\.]*,[0-9]*`)
var str = `9,99
123,12
12,3
121,
10,
,10
,00000
13,0923
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}