import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9\\.]*,[0-9]*";
final String string = "9,99\n"
+ "123,12\n"
+ "12,3 \n"
+ "121,\n"
+ "10,\n"
+ ",10 \n"
+ ",00000\n"
+ "13,0923 \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}