$re = '/[0-9\.]*,[0-9]*/m';
$str = '9,99
123,12
12,3
121,
10,
,10
,00000
13,0923
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);