package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https?:\/\/\S*`)
var str = `some text before http://some_domain.com/some_link some text before https://www.some_domain.com/some_link some text after`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}